Installation

Version1.0.0

Voraussetzungen

Java17 Magnolia6.2.40 Magnolia Image Recognition Module1.2.5

Die minimale Java Version, die das Modul unterst├╝tzt ist, Java 17 und die minimale Magnolia Version, die wir unterst├╝tzen, ist Magnolia 6.2.40. Des Weiteren wird Magnolias Image Recognition Modul in der Version 1.2.5 ben├Âtigt.

Dieses Modul ist ein Image Recognitor f├╝r Magnolias Image Recognition Module.

Maven Dependency

Es wird folgenden Dependency in der pom.xml der WebApp gebraucht:

<!-- Voraussetzungen -->
<dependency>
    <groupId>info.magnolia.ai.image</groupId>
    <artifactId>magnolia-image-recognition</artifactId>
    <version>1.2.5</version>
</dependency>
<dependency>
    <groupId>info.magnolia.ai.image</groupId>
    <artifactId>magnolia-content-tags-integration</artifactId>
    <version>1.2.5</version>
</dependency>

<!-- Das Modul -->
<dependency>
    <groupId>com.dev5310</groupId>
    <artifactId>gpt4-imagerecognition</artifactId>
    <version>1.0.0</version>
</dependency>

Das Modul liegt in der dev5310 Artifactory, weshalb auch folgendes Repository in der pom.xml hinzugef├╝gt werden muss:

<repository>
    <id>dev5310</id>
    <url>https://artifactory.dev5310.com/artifactory/lib-release-public</url>
</repository>